Loading...
 

ALIF: Original AIM Upgrade

 Important

If you are running an AIM whose firmware is older than v2.1 then please contact Adder Support before proceeding.

From January 2018, an issue with the SSL certificate generation was discovered with the original AIM Server when running 3.3 firmware. In order for the AIM Manager(s) and the endpoints to both trust each other and to communicate securely, the AIM(s) and endpoints require a valid SSL certificate. Due to a 32-bit overflow error, certificates that are generated for the AIM and endpoints after this date are invalid. Therefore to resolve this issue, a v3.5 firmware update was released. However, if you are upgrading from a pre-3.3 AIM firmware release then you will need to use one of the upgrade procedures below:-

Upgrading from AIM Firmware v2.5

  1. Disconnect AIM from the main network.
  2. Upgrade from 2.5 to 3.3.
  3. Make a backup.
  4. Upgrade from 3.3 to 3.5.
  5. Factory reset the AIM
  6. Restore the backup.
  7. Reconnect the AIM to the main network..
  8. Upgrade the endpoints.to v3.7

Upgrading from AIM Firmware v3.1

  1. Disconnect AIM from the main network.
  2. Upgrade from 3.1 to 3.3.
  3. Make a backup.
  4. Upgrade from 3.3 to 3.5.
  5. Factory reset the AIM
  6. Restore the backup.
  7. Reconnect the AIM to the main network..
  8. Upgrade the endpoints.to v3.7

Upgrading from AIM Firmware v3.3

  1. Make a backup.
  2. Upgrade from 3.3 to 3.5.
  3. Factory reset the AIM
  4. Restore the backup.
  5. Upgrade the endpoints.to v3.7


 Note

If you have any endpoints which failed to be added to the AIM whilst running 3.3 and after January 2018 then you will need to factory reset the endpoint before it will be seen by your AIM running 3.5.

If you do not have a copy of the older AIM firmware, please contact the Adder Support team.


Page last modified on Thursday December 12, 2019 16:39:38 GMT-0000